CalendarCalendar   Photos  * FAQ
It is currently Wed Sep 17, 2014 2:32 pm

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: Red Label problem
PostPosted: Sun Jun 28, 2009 2:52 pm 
Tournament Grade

Joined: Mon Nov 05, 2007 2:29 pm
Posts: 130
I was shooting with friend today and his Red Label was seeping a rusty colored liquid from the joint where the top bbl is joined to the monoblock. Is this a common problem, do you think Ruger will fix it? This is a very early 20 gauge


Top
 Profile  
 
 Post subject: Re: Red Label problem
PostPosted: Mon Jun 29, 2009 11:36 am 
Limited Edition

Joined: Wed Dec 21, 2005 10:31 am
Posts: 320
Location: Las Vegas, Nevada.
YES-----------This is a problem, don't shoot the gun ---barrel is loose in monoblock---send it back to ruger they will repair replace as needed!!!


Top
 Profile  
 
 Post subject: Re: Red Label problem
PostPosted: Mon Jun 29, 2009 6:44 pm 
Tournament Grade

Joined: Mon Nov 05, 2007 2:29 pm
Posts: 130
I thought it was the joint coming loose too. Today he called Ruger and they said that it was OK to shoot :shock:

He's going to get a second opinion from a gunsmith. He bought this gun new about 1979 and this happened for the first time yesterday.


Top
 Profile  
 
 Post subject: Re: Red Label problem
PostPosted: Tue Jun 30, 2009 2:57 pm 
Diamond Grade

Joined: Fri Oct 29, 2004 11:37 am
Posts: 1995
Location: Virginia
Apparently this is pretty normal for a Ruger. Mine does the same thing. Other people have also contacted Ruger, only to be told it is normal. The subject comes up fairly frequently on this board.


Top
 Profile  
 
 Post subject: Re: Red Label problem
PostPosted: Sun Aug 02, 2009 9:11 am 
Field Grade

Joined: Sat Jun 20, 2009 12:03 am
Posts: 55
I have several Red Labels and they all "Leak."
These include 12 and 20 Sporting Clay models, a 20 (26") Engraved and a 28 (26").
I just don't let it bother me.
Most of these have a ton of rounds through them also and the "Leakage" thing showed up early so I believe it to be "Normal" also.


Top
 Profile  
 
 Post subject: Re: Red Label problem
PostPosted: Sun Aug 02, 2009 11:55 am 
*Proud to be a*
*Proud to be a*
User avatar

Joined: Wed Nov 16, 2005 12:32 pm
Posts: 18008
Location: Capital District, NY
It's a known common problem with the way that Ruger constructs the Red Label...


Top
 Profile  
 
 Post subject: Re: Red Label problem
PostPosted: Mon Nov 16, 2009 11:24 pm 
Tournament Grade

Joined: Sat Jul 05, 2008 4:43 pm
Posts: 143
Location: Williamsburg, VA
I know this is an old thread but...

it seems people talk about this being a problem. One of the old guys (you know, the 70 year old guy who was a state champion back in high school and still shoots better than everybody) who has a few Red Labels was talking about this the other day - apparently it's something involved with the process of silver soldering, and it stops after about 400 rounds. Don't know why this doesn't jib with tnn58's experience.


Top
 Profile  
 
 Post subject: Re: Red Label problem
PostPosted: Tue Nov 17, 2009 9:40 am 
*Proud to be a*
*Proud to be a*
User avatar

Joined: Wed Nov 16, 2005 12:32 pm
Posts: 18008
Location: Capital District, NY
marlinspike wrote:
it stops after about 400 rounds.


I bought mine used, with tens of thousands of rounds fired through it, and I've put another 2500 or so through it... it still "leaks".


Top
 Profile  
 
 Post subject: Re: Red Label problem
PostPosted: Tue Nov 17, 2009 4:53 pm 
Presentation Grade

Joined: Sun Apr 12, 2009 10:12 am
Posts: 620
Location: Tennessee
drsfmd wrote:
marlinspike wrote:
it stops after about 400 rounds.


I bought mine used, with tens of thousands of rounds fired through it, and I've put another 2500 or so through it... it still "leaks".

Didnt you just tell me you didnt even own a shotgun?? :?

_________________
Somewhere in Kenya, a village is missing its IDIOT..
Perazzi MX8 trap 12
CG Summit Unsingle
Citori 12
Citori 20
7..1100's
Charles Daly 12
Ithaca 37 16
Ithaca 37 20


Top
 Profile  
 
 Post subject: Re: Red Label problem
PostPosted: Tue Nov 17, 2009 5:49 pm 
*Proud to be a*
*Proud to be a*
User avatar

Joined: Wed Nov 16, 2005 12:32 pm
Posts: 18008
Location: Capital District, NY
blkcloud1 wrote:
Didnt you just tell me you didnt even own a shotgun?? :?


I don't! :wink:


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Registered users: 4tenman, Aircooled6racer, analyst, awmp, Baron23, BayouSlide, Bentleybob, billd3, Bing [Bot], cannon cocker, cthemfly, dbuffington, Dirtweed, Diyelker, drcook, ds cowboy, EnVmyIX, estes640, FreeShot, FWP, gmangh15, Google [Bot], Google Adsense [Bot], Google Feedfetcher, hawglips, HogRider357, hoogie, HoosiershooterinPA, hopper810, ILLINOIS, irishthunder, Irishwhistler, jandat, Jaspo01, jdtrio, JeffreyPhD, JoeFro, KRIEGHOFFK80, lefty o, Louisdmt, Majestic-12 [Bot], marist89, May, nanuk, Norbert_Nagy, novasbc, oinodam, Old Reliable, oregunner, pflyrodder, piano2ner, pitted bore, rgonzo, rickeroo, rolawson, scottyhammond, sera, simsy9, SmoothboreHunter, Snotrub, Splice, sportingspecial, strut64, SuperXOne, talbtimber, tjen, TRG3, valentine, Virgil, William1976, Wing_Shoot, zEaglett


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group     -  DMCA Notice