It is currently Tue Nov 21, 2017 1:13 am

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 14 posts ] 
Author Message
 Post subject: Ejector problem on Red Label
PostPosted: Sat Jul 31, 2004 11:06 pm 
Field Grade
User avatar

Joined: Sun Jul 04, 2004 6:34 pm
Posts: 46
Location: Rockwall, Texas
I have a Red Label 20 ga, 50th Anniversary model. Recently, I've had a problem with the ejector on the lower barrel. With certain brands of ammo (Fiocci & Winchester), when I place a shell in the barrel, it occasionally falls past the ejector. I then have to pull it out or the gun won't close. If I use Remington STS, this never happens.

Is this something anyone else has experienced? Is it just bad ammo or should I send the gun in for repair?



_________________
Greg


Top
 Profile  
 
 Post subject: Re: Ejector problem on Red Label
PostPosted: Sat Jul 31, 2004 11:37 pm 
Crown Grade
User avatar

Joined: Mon Nov 10, 2003 11:09 pm
Posts: 11603
Location: Houston, Texas
WHOOPS!!! Wrong forum...

Nick

_________________
It is time I stop accepting the things I cannot change and start changing the things I cannot accept.

Image


Top
 Profile  
 
 Post subject: Re: Ejector problem on Red Label
PostPosted: Sun Aug 01, 2004 1:54 pm 
Tournament Grade

Joined: Tue May 11, 2004 5:35 pm
Posts: 100
Location: Alfred Maine,USA
I'd get it checked with your gunsmith,may be bent or worn ejectors.-Nick,why is this the wrong forum?

_________________
Of course I missed that last clay,it was a hen!


Top
 Profile  
 
 Post subject: Re: Ejector problem on Red Label
PostPosted: Sun Aug 01, 2004 2:19 pm 
Crown Grade
User avatar

Joined: Mon Nov 10, 2003 11:09 pm
Posts: 11603
Location: Houston, Texas
It was just a joke... I'm known on this board as not liking the RRL's very much and when I saw that there was a problem with one, I thought I'd voice myself...

Sorry if you think it was in poor taste...

Nick

_________________
It is time I stop accepting the things I cannot change and start changing the things I cannot accept.

Image


Top
 Profile  
 
 Post subject: Re: Ejector problem on Red Label
PostPosted: Sun Aug 01, 2004 8:23 pm 
I've had the same problem with Fiocchi's in my RL. I've also had the same problem with Fiocchi's in my Beretta. Other members of my informal skeet group have had the same problem in Citoris, Weatherbys and just about any kind of autoloader you can name. We've even had trouble with 870's and Mossy 500's. SOmhow I don't think it's the guns!


Top
  
 
 Post subject: Re: Ejector problem on Red Label
PostPosted: Sun Aug 01, 2004 8:45 pm 
Crown Grade
User avatar

Joined: Sat Nov 08, 2003 1:52 pm
Posts: 6174
Location: Ontario, Canada
French Double wrote:
SOmhow I don't think it's the guns!


My shotgun, clay target reloading experience began in 1970.

I don't think in this case I am influenced by nostalgia for the "good ol days" but it seems to me in the last 15 years there is more substandard ammo out there compared to the AA's, Rem RXP's and Fed that were almost exclusively used at the clubs I shot at back then.

It may be the extremely price concious market we seem to have today may be lowering the standards these days more than in the past.

I believe this is why at least some of these problems occur.


Top
 Profile  
 
 Post subject: Re: Ejector problem on Red Label
PostPosted: Thu Aug 05, 2004 9:15 pm 
Utility Grade

Joined: Thu Oct 02, 2003 10:52 am
Posts: 17
I have an RRL 20, but have only put 2 boxes of ammo thru it, so not really acquainted with the gun yet.

If I have trouble with minewithin the next 5 years, I'll probably get rid of it. I didn't pay $1000 for it to turn around and take it to a gun smith !!!.


Top
 Profile  
 
 Post subject: Re: Ejector problem on Red Label
PostPosted: Sun Aug 15, 2004 4:54 am 
Gee, I used to be able to spell.
My informal skeet club just bought a bunch of Winchester Super Speed shells. We changed brands due to the problems we were having with Fiocchis. None of us have noticed any ejection problems but we have found some with loose crimps and also some squib loads.


Top
  
 
 Post subject: Re: Ejector problem on Red Label
PostPosted: Sun Aug 15, 2004 7:27 am 
Field Grade
User avatar

Joined: Sun Jul 04, 2004 6:34 pm
Posts: 46
Location: Rockwall, Texas
Problem solved. I traded the Red Label in for a Beretta Blackwing. It shoots anything I feed it.

_________________
Greg


Top
 Profile  
 
 Post subject: Re: Ejector problem on Red Label
PostPosted: Thu Aug 19, 2004 11:30 am 
I worked with Red labels all summer and we had 7 of the 11 fail due to the ejector problems on our 12 gu's.


Top
  
 
 Post subject: Re: Ejector problem on Red Label
PostPosted: Fri Aug 20, 2004 4:05 am 
Knock on wood ... I have new 20 and 28 Engraved Models that have not had any trouble. Shoot Sporting clays with them often. Shot my highest score ever (in any gauge including 12) at a large tournament last time out with the 20.


Top
  
 
 Post subject: Re: Ejector problem on Red Label
PostPosted: Tue Oct 19, 2004 7:00 am 
Tournament Grade

Joined: Mon Oct 04, 2004 6:15 pm
Posts: 123
Location: MN, USA
I have had my Red Label since 1981 and have put many shells through it on live birds, trap & skeet and have NOT experienced the ejector problem with anyones ammo. I guess they don't make 'em like they used to!


Top
 Profile  
 
 Post subject: Re: Ejector problem on Red Label
PostPosted: Tue Oct 19, 2004 8:28 am 
*Proud to be a*
*Proud to be a*

Joined: Mon Aug 16, 2004 9:26 pm
Posts: 8311
Location: Asheboro, N.C.
GSonnen: I know of 3 different people that shoots Ruger Red Label's, 28 gauge an they all have the same problem with the Fiocchi an Cheddite hulls. They don't have any problem with STS's or AA hulls getting past the injectors when loading, so it must be a problem with the other hulls. It can't be bent ejectors or it wouldn't eject the STS's or AA's I would think.

_________________
Don


Skeet aren't hard to hit, just easy to miss....!!


Top
 Profile  
 
 Post subject: Re: Ejector problem on Red Label
PostPosted: Wed Nov 17, 2004 8:54 pm 
Utility Grade

Joined: Tue Feb 10, 2004 6:03 pm
Posts: 8
I had this problem with my 28 ga., no matter what brand hull I used. Sent it back to Ruger. It took two trips, but they fixed it free of charge, and even replaced the stock free of charge, even though I told them that I damaged it. Ended up replacing both ejectors, safety detent springs, and some other small parts that escape me right now. It's functioned for over 1000 rounds since, without a hitch. They have definitely earned a life long customer. I've also got a stainless 12ga, and have had no issues, with several thousand rounds fired.




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Registered users: andlours, Bing [Bot], bulljiggy, CMH, Diddle, doppelflinten, Google [Bot], Google Adsense [Bot], Jaspo01, jcbabb, Joel45acp, Knipan, Maser, Michael_, muskrat mike, nikobe, Peterjoymn, RGK, Rooster booster, ShowMe2, smlekid, SuperXOne, Texas Yankee, VTHokiesDuckHunter, WillieArima


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Jump to:  
© 2017 Carbon Media Group Outdoors    - DMCA Notice