ShotGunWorld Shotguns

It is currently Wed Jan 27, 2021 2:53 am

All times are UTC - 6 hours [ DST ]


Image



Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Beretta A400 not cycling heavy loads
PostPosted: Sat Jan 02, 2021 7:01 pm 
Utility Grade

Joined: Sat Jan 02, 2021 6:52 pm
Posts: 1
Beretta A400 will not cycle heavy (3") duck loads. Jams after 1st shell is shot.
Shoots light (dove) loads fine. Shot over 100 dove hunting yesterday.
Have sent the gun back to Beretta twice and they say no problem.
There IS a problem.
Very frustrated at this point.
Help?




Top
 Profile  
 
 Post subject: Re: Beretta A400 not cycling heavy loads
PostPosted: Sat Jan 02, 2021 9:06 pm 
Shotgun Expert
Shotgun Expert
User avatar

Joined: Sat Sep 09, 2006 11:02 am
Posts: 27050
Location: Plainfield, IL
The default solution for Beretta pollution is Cole Gunsmithing and has been for many, many years. https://colegun.com/

_________________
--Randy

http://randywakeman.com/


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Registered users: Bing [Bot], elvas, Feeeetask!, Google [Bot], Google Adsense [Bot], johnnie g, Majestic-12 [Bot], medic319, mpolans, oldshotty, rickeroo, Rudolph31, skeetsit, smlekid, SoCalshot, Steeler [Crawler], SuperXOne, WaySheGoes


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group    - DMCA Notice