ShotGunWorld Shotguns

It is currently Sun Sep 20, 2020 12:40 am

All times are UTC - 6 hours [ DST ]


Image



Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Powder and shot drop variations.
PostPosted: Fri Feb 14, 2020 7:41 am 
*Proud to be a*
*Proud to be a*
User avatar

Joined: Fri Mar 25, 2011 6:37 pm
Posts: 1873
Location: Eastern Oregon
My 9000H has been remarkably consistent with drops of powder and shot. I have a UCB on it and use Vectan AS, Green Dot and Titegroup powders. Just finishing a flat of Gold Medal hulls and noticed intermittent failure of charge bar to make a full travel..... resulted in several light powder drops :?: :?: . Checked the usual stuff and found no issues. Went back to loading and everything fine till the operating rod for the charge bar detaches :?: :?: ....
More careful examination revealed the screw that hold the bracket to the back side of the charge bar had loosened allowing that bracket to move, sometimes it worked, sometimes it did not and finally moved to the point the actuating rod jumped off the lever :idea: :idea: . Called a buddy and his had come loose also... not quite as loose but loose just the same. Might be something to check......... Larry




Top
 Profile  
 
 Post subject: Re: Powder and shot drop variations.
PostPosted: Fri Feb 14, 2020 8:01 am 
Diamond Grade
User avatar

Joined: Sun Jun 24, 2018 2:51 pm
Posts: 1562
Location: S.E. Wisconsin
A UCB issue only I assume because there is no "bracket" on the backside of any of my MEC charge bars.

Steve

_________________
The More Times You Pull The Trigger The More Fun You Are Having.
I repair MEC presses. PM me.
Used to be Steve Y


Top
 Profile  
 
 Post subject: Re: Powder and shot drop variations.
PostPosted: Fri Feb 14, 2020 11:27 am 
*Proud to be a*
*Proud to be a*
User avatar

Joined: Fri Mar 25, 2011 6:37 pm
Posts: 1873
Location: Eastern Oregon
I also use the roller bearing on the actuating lever Steve. With the loose bracket screw the bracket was moving enough to cause the point on the nut to dig into and bind on the alloy bracket. That is what caused the rod to drop off and allow me to locate the problem. Definitely not a MEC issue. My son has my OLD 650, a friend has my OLD 9000H and both have my OLD UCB's on them. Jillions of rounds through them and not any problem....... Larry


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Registered users: 98052, AuburnAlum, Bing [Bot], CCskeetr, driller, Google [Bot], Google Adsense [Bot], Google Feedfetcher, Jaspo01, John H, LoFlyer, Majestic-12 [Bot], MeatSweats, MichaelJohnsrud, ohio mike, oldshotty, olsenjb, popcorn09, smlekid, Stuck-N-Kali, tractman, Trapperjohn01, tschlemm, Waldyo


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group    - DMCA Notice