ShotGunWorld Shotguns

It is currently Sat Jan 23, 2021 4:32 pm

All times are UTC - 6 hours [ DST ]


Image



Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Winchester SX3
PostPosted: Wed Jan 06, 2021 11:45 am 
Utility Grade

Joined: Sat Oct 10, 2020 12:55 pm
Posts: 4
Has anyone here every had an issue with this gun or other 3.5" guns not pulling the next shell into the chamber after firing the first 3.5 shell? Never happens with 3" shells, but happened once every 7-8 shots this past week duck hunting.




Top
 Profile  
 
 Post subject: Re: Winchester SX3
PostPosted: Wed Jan 06, 2021 1:47 pm 
Diamond Grade

Joined: Sun Jan 14, 2007 1:46 pm
Posts: 1199
Not sure this is a perfect solution but the 3 1/2 inch shells have a higher pressure max. and cause higher bolt speed. Possibly replacing the action spring will help to slow down the bolt and give time for the lifter to get the second shell in proper position to chamber correctly..

It may also help to clean out the action spring tube as well as the mag tube to be sure both of them a free of anything that could slow down the second shell from getting into place on the lifter to properly chamber.

These suggestions are based on the fact that 3 inch shells function properly and neither of these suggestions is expensive or difficult.


Top
 Profile  
 
 Post subject: Re: Winchester SX3
PostPosted: Wed Jan 06, 2021 5:37 pm 
Limited Edition

Joined: Fri Dec 27, 2019 7:22 pm
Posts: 353
Location: NE South Dakota
Yes, the culprit was the action spring in the stock. Cleaned and lightly lubed took care of the issue. Mine would push the shell only 1/4 the way into the chamber or hang up prior making the chamber.

It’s amazing what can get inside there. The last time it happened I somehow got a chunk of cattail into the action spring in the stock and a chunk of reed grass.


Top
 Profile  
 
 Post subject: Re: Winchester SX3
PostPosted: Mon Jan 11, 2021 12:12 pm 
Utility Grade

Joined: Sat Oct 10, 2020 12:55 pm
Posts: 4
THanks guys.....I cleaned it today and the action was moving much more smoothly. Illl see what happens on the next hunt. Cleaned the one on my beretta 303 today also. Man that thing was nasty.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Registered users: 9fingers, AJ-M12, Artistic License, bbludau34, beaglemusic, Bigdog100, Biigote, Bing [Bot], casonet, cbradford, clayaddiction, Coach B, Combat Sausage, Curly N, D McMillen, DavidRamey, dpe2002, drawdc, dukman22, ebcjr, EricB, ezz555, fishrising, FlyChamps, Google [Bot], Google Adsense [Bot], Google Feedfetcher, greg5278, ithacanut, jbmich, JJPinOhio, Keperkey, kjs, liveblues, Majestic-12 [Bot], Major146, Malcolm7, Mark Pfeifer, McFarmer, mickd, misterdom, noweil, oneounceload, painter*, Rack-N-Roy, railroad, Reinar, remdog1187, rickeroo, roguepilot, saskbooknut, senoiaslim, shacked, sherpa guide, smlekid, snooky, Starstorm, Station9, SWPAMike, T-Pee, Tom Bryant, Vette Jockey2, Westender, Wheelspin, wjonessc, ysr_racer, zxcvbnm


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group    - DMCA Notice