Shotgunworld.com
https://www.shotgunworld.com:443/bbs/

SBE 2 double feeding
https://www.shotgunworld.com:443/bbs/viewtopic.php?f=61&t=313049
Page 1 of 1

Author:  garza7585 [ Tue Nov 06, 2012 8:17 am ]
Post subject:  SBE 2 double feeding

Hey guys im having an issue with my somewhat new SBE 2.

In the last 2 weeks i've had 2 double feeds from my gun. I'll shoot and the shell ejects and then the last two shells feed. One will be out in the lever and about a half inch from the other one would be poking out of the magazine as well keeping the first one from feeding.

Its happened with a clean gun and with a dirty gun. The last time it malfunctioned, I cleaned it I pulled the plug and mag spring to clean it as well.

Any other ideas of what might be the issue?

posted using Outdoor Hub Campfire

Author:  Worc [ Tue Nov 13, 2012 10:35 pm ]
Post subject:  Re: SBE 2 double feeding

make sure the trigger group is clean as that controls the timing of the gun. Also make sure the magazine stop in the receiver is clean and moving freely.

You can test it out by dry firing the gun with rounds in the magazine tube. Once you pull the trigger the first round in the magazine will be released.

Author:  brookie [ Fri Nov 16, 2012 5:21 pm ]
Post subject:  Re: SBE 2 double feeding

Make sure you are feeding the shells all the way into the tube also. mine will hold the shell in the tube but will not cycle properly if it is not pushed all the way in. I do this sometimes when I have gloves on.

Author:  tnmac [ Sun Nov 25, 2012 10:53 am ]
Post subject:  Re: SBE 2 double feeding

This has happened to my son's SBE II this last and this weekend while duck hunting. Cleaned/ oiled everything this week but still happened yesterday. Didn't have trouble at all during recent dove shoots. Changed from hevi-metal to kent shells this morning. So far now problem today. Took it apart yesterday and looked at all parts involved and it released perfectly in that setting. Frustrated :(


Posted using Outdoor Hub Campfire

Author:  garza7585 [ Tue Nov 27, 2012 9:04 pm ]
Post subject:  Re: SBE 2 double feeding

Mine hasn't malfunctioned since I posted the topic.

I cleaned my mag tube and spring which was suprisingly dirty for how new the gun is. I also stretvhed my mag spring a bit.

Then after a tip from Worc I pulled my trigger group and sprayed it generously with CLP and blew as much as I could out. My trigger group was FILTHY.

Im guessing the carrier was binding or not moving as smooth with it being as dirty as it was. I also check my shell latch and spring to make it was clean as well.

So far, so good and ive been huntin alot...



posted using Outdoor Hub Campfire

Page 1 of 1 All times are UTC - 6 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/