ShotGunWorld Shotguns

It is currently Thu Jun 17, 2021 4:41 pm

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: M1/M2 receiver wear + shell loading hesitation
PostPosted: Wed Feb 10, 2021 1:41 pm 
Utility Grade

Joined: Fri Feb 05, 2021 12:58 pm
Posts: 7
Location: So Calif.
I noticed that after ghost loaded a shell onto the carrier of my M1 (with or without shells in magazine). Then tried to rack the bolt to load the ghost round, the bolt would often hang up on the back , unable to lift the shell up and chamber the round. However, as soon as I either applied a little forward pressure on bolt, lift up on carrier, or press magazine latch. it will easily chamber the round. Round doesn't have to be ghost loaded to do this as If i release a shell from magazine with the lever, and try to rack the bolt, it does the same thing.

I completely stripped and cleaned trigger group, cleaned/reoiled recoil spring, cleaned and reoiled bolt and inside receiver.

Now it is a lot better, but will still want to hang up trying to load the shell on the lifter with nothing in the magazine tube. If there are rounds in the magazine, then it seems to load normally.

I read that this issue could sometimes stem from a worn magazine latch spring (have one on the way).

However Looking inside the receiver I noticed that it has a lot of wear, opposite side to magazine latch. it is slightly gouged/galled. It kind of looks like the rim of the shell is hanging up on the gouge in the receiver. Is there a reason why my gun has so much wear here or just normal for high round count benelli's.

Mods:
Nordic +5 ext and spring.
TTI Reduced power recoil spring
(I haven't fired the gun in several months however, last time I went out i went through about 100 rounds (hi brass, 00buck, light game loads) no malfunctions, and didn't notice shells hanging up).

I ordered the following:
Mag latch spring
Carrier spring.

Any one else have wear marks like mine? Or perhaps My nordic magazine spring is too long/powerful and causing shells to be sent onto my lifter too hard, then gouging the receiver.

I will note that I am not original owner of gun, and when I got it , i had non-stop FTE issues with any/all loads. Replaced pistol grip with conventional stock, and put in the reduced power spring, and began to cycle everything.

thanks all.




You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 6 hours [ DST ]


Who is online

Registered users: 1977cutcher, acorad, Bamaskeetshooter, bambam21, bigbluedodge, Bing [Bot], bladesmith, Blockcaver, casonet, creeker, dagnarble, DanG, Denver1911, double20, Drew Hause, DUKFVR, Eibar, fishrising, Gadwall, Google [Bot], Google Adsense [Bot], gunut 1, hopper810, hunter981, Huntr104, Jason Johnson, jlssd1, JoeEddie, John20, jrmev, Keperkey, kgwolo, Kycrawler, Life of Riley, mickd, Mike916, MTmag, P.Muerrle, painter*, Pine Creek/Dave, Pullandmark, remdog1187, senork, sneem2, southdakbearfan, soyknee, Ssanders224, steve204me, superskeet, Texsss, thecoinopcollector, tracker 6, Tvbh40a, Tylerhc, WAGinVA, Waldyo


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group    - DMCA Notice