Shotgun Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I just bought my first 16 gauge and had it out hunting phesants. I shot two shells and the third went into the chamber. I shot another two shells after that and went to fire it a third time and it jammed with the bolt to the back. One shell was going into the chmaber and the other shell had pushed the latch up. I could not get it to unjam.

I took it to a local gunsmith and he took it apart and one of the two rods going into the stock was not in place, he put in back in.

Today I shot three shells and all worked well. Loaded some more shells and the next shot it just clicked. I could not get it unjammed with the bolt forward. I took the gun apart to get all the shells out, put the gun back together and I still could not get the bolt to come back.

I am very unfamiliar with these guns so any help would be appreciated.

Thanks!
 

·
Registered
Joined
·
607 Posts
Are you getting the cap that holds the forearm and berrel on screwed down tightly? If the bolt is coming forward too far the "link" pins that are attached to the back of the bolt will pop off the follower that the action spring pushes against. You may have a weak action spring too or crud in the tube it rides in. Go to Numrich gun parts and look at the exploded parts diagram and you will see all this stuff. Good luck, these are great guns.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top