Shotgun Forum banner
21 - 40 of 44 Posts

·
Registered
Joined
·
303 Posts
I have a 20ga a400 xplor and I have run everything from heavy 3” steel loads to light 3/4oz skeet loads with no issues minus a box of 3” rio steel loads that was clearly out of spec.
 

·
Registered
Joined
·
367 Posts
How old are y’all’s xplors that malfunctioned? Mine is pretty new bought in September if I recall. I wonder if the port issue was fixed on the newer ones?
The Xplor and lite that I shot are both 2018 models. Neither had issue with 1oz loads or higher. They just wouldn’t cycle 7/8oz 1200fps loads.
 

·
Registered
Joined
·
345 Posts
Discussion Starter · #29 ·
Finally got to go try out my 20 gauge Xcel. First up a box of Federal Top Gun 7/8 oz, 71/2 shot, 1210 FPS, and it ran flawlessly, then tried a box of Winchester Universals 7/8 oz, 8 shot, 1200 FPS. Had 3 malfunctions. The same thing I was experiencing with my Beretta AL2 12 gauge with Winchester Super Target. Looks like Berettas don't like Winchester or at least mine don't.
 

·
Registered
Joined
·
916 Posts
How old are y’all’s xplors that malfunctioned? Mine is pretty new bought in September if I recall. I wonder if the port issue was fixed on the newer ones?
No. Bought one last December and would not cycle any 1200 fps target loads. Coles will fix it.
The whole “break in with heavy loads” is BS.
 

·
Registered
Joined
·
303 Posts
Interesting, like I said mine works with everything down to 3/4 oz light loads. It does have a few hundred magnum shells down the pipe along with thousands of target shells. Mine has enough gas pressure to score the bolt pin up. I love the gun but worry about longevity.
 

·
Registered
Joined
·
345 Posts
Discussion Starter · #32 ·
I don't think it has to do with light loads. I think it just doesn't like Winchester ammo. I know my AL2 doesn't. All my reloading gear is in storage at the moment waiting for our new home to get finished, so I can't really test it out. I am going to go to Scheels today and see what I can find. The A400 28 works great with the factory Top Gun which is basically the same load as the factory Winchester I was trying, which did not work. I can run 7/8 ounce at 1150 FPS in Gold Medal hulls all day long in my AL2 but it won't cycle factory Winchester 1 1/8 ounce at 1200 FPS at all.
 

·
Registered
Joined
·
367 Posts
Mine functions those flawlessly. That’s some bad qc on beretta’s behalf. That malfunction almost looks like the return spring is weak or is that an empty?
It’s an empty. It is my daughter’s bf’s gun. He says it has never cycled light loads. He dove hunts with it, but has to use 1oz loads. The lite I tried a few years ago did the same thing.
 

·
Registered
Joined
·
367 Posts
Man, that’s too bad, is it past the warranty?
Yes. It’s a 2018 model. Drilling out the gas port is likely an option for this one, but he’s hesitant to do it after seeing the over gassing issue with the lite when shooting 3” loads. I tried to convince him he’d likely never use it for waterfowl hunting, so he’d likely never put 3” loads through it. He said he may pheasant hunt with it. I’m a big fan of the 12 gauge A400 line. I just haven’t had the same luck with the 20 gauge A400 line. I recently purchased an A300 Ultima in 20 gauge and it cycles everything. IMO much better gun for half the price
 
21 - 40 of 44 Posts
Top