Shotgun Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
961 Posts
Discussion Starter · #1 ·
Veloicity Xlr
The clip broke part #G-017. The clip that holds the part that slides on the magazine tube. Any suggestions on how to replace the clip?
I don't have the part, will call FabArm for a replacement.. 10Tenner
 

·
Registered
Joined
·
398 Posts
I had the same thing happen to mine. They sent me one free of charge. It was a bugger to get back on, though. I was without my tools the day it came in and I was on my way to the shoot. What I ended up finally succeeding with was to place the clip fully around the G-189 part first. Next I started one 'ear' of the clip into the G-138 rail with the G-189 part almost at 90 degrees. Then, while applying consistent pressure keeping both parts together, I rotated the G-189 part into place, allowing the clip to seat into the G-138 rail.

Sounds easy, right?
 

·
Registered
Joined
·
961 Posts
Discussion Starter · #5 ·
Received the clip part today. Clamped part G-189 in a vise, rotated G-138 & G-17 (clip) 90 degrees or to the side of G-189. Started both ears into the slide, not fully extending over the top of the slide, keeping pressure and rotating up and aligning parts.
I had to squeeze the ends of the clip in farther slightly bending them, due to the new part being different. The new part is radiused below the ears and the ears extend out more. Not having an angle eliminating stress at the bend were the angle is. This is were my part broke.
Jcbabb, again thanks for the information. 10Tenner
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top