Shotgun Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Well I guess I was about due.. own 5 Brownings never had a days trouble.. Today I did...

I have a 525 (mind you this gun is brand new... less than 50 rounds shot through it) today while shooting it just stopped working. It acts like the triggers never reset after its been fired... If I messed with it long enough sometimes it would work.. but not consistant at all!

Any Idea's as to what might be wrong? Also does anyone have any experience with replacing a inertia Trigger with a pure mechanical one? If the problem really is the trigger I am considering doing just that!

Thanks in advance for any advice or insight anyone has!!!
 
G

·
I have seen this problem before. Check for any burrs or rough spots on the sears or block. It can be changed to a mechincal trigger without replacing any parts. Bob R&D.
 

·
Premium Member
Joined
·
2,666 Posts
Thanks for stopping by Bob, heard good things about you and your shop.

If this is a new gun could it also still have some stiff grease in the mechanism?
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #5 ·
It was actually stiff grease.. I had posted this in two of the forumns accidently( I lost the first one somehow ..lol) and once I pulled the stock and cleaned it out real good it seems to work just fine.. Ty all for your posts on this...
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top