Shotgun Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2,227 Posts
Discussion Starter · #1 ·
Anyone have a replacement carrier stop working after many rounds--perhaps 10,000? It appears that I am beginning to have a second round failure to chamber. (right side hangup) Occasional I have a first round failure too.

Replaced the recoil spring hoping that was the problem, no joy. My current plan is to do a even closer inspection tomorrow of the trigger group and the carrier, and if I don't see anything obvious I'll order a carrier from Cole and hope.

Thanks
 

·
Registered
Joined
·
9,163 Posts
I'm curious about which type of carrier this is - the straight 391 type or the curved 390 type?

If is is straight, I would be inclined to guess that the problem is indeed in the carrier. But I'm not sure. It is unusual for the first round to hang up, and that might indicate the problem is something other than the carrier.

Where did you get your replacement carrier? If it was from Cole, call them and talk to Jim Bellegarde and ask if they have seen that happen before.

I have heard of carriers going bad after several thousand rounds, but 10,000 is a lot.

Try removing the carrier and do the table-top test described in the "Disassembly" stickey, and let us know the results.
 

·
Registered
Joined
·
2,227 Posts
Discussion Starter · #3 ·
I got my replacement carrier from Cole the first time around. Will do the table top test and eyeball everything. Last time the problem seemed to develop progressively from an occasional hang-up to a four time in a row problem. Actually, I believe, I had two problems at the time-recoil spring and carrier.

Off to the shop to do the eyeball everything. Thanks for your response.

Added after the I looked again.

Did a thorough cleaning: checked the gas ports they were clean, cleared one of the four holes in the gas relief cylinder, pulled the trigger group cleaned and lubed and used the compressed air to remove any extra lubricant from trigger group and so on. Reassembled with a wet gas system...

Took it to the range and it worked perfectly. Will run some more rounds tomorrow and when it runs perfectly I will scratch my head and wonder why I reported a problem in the first place. My current theory is that the 391 wanted more attention after running many thousands of rounds with any problems.
 
1 - 3 of 3 Posts
Top