Shotgun Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
2,216 Posts
Discussion Starter · #1 ·
Anyone have a replacement carrier stop working after many rounds--perhaps 10,000? It appears that I am beginning to have a second round failure to chamber. (right side hangup) Occasional I have a first round failure too.

Replaced the recoil spring hoping that was the problem, no joy. My current plan is to do a even closer inspection tomorrow of the trigger group and the carrier, and if I don't see anything obvious I'll order a carrier from Cole and hope.

Thanks
 

· Registered
Joined
·
2,216 Posts
Discussion Starter · #3 ·
I got my replacement carrier from Cole the first time around. Will do the table top test and eyeball everything. Last time the problem seemed to develop progressively from an occasional hang-up to a four time in a row problem. Actually, I believe, I had two problems at the time-recoil spring and carrier.

Off to the shop to do the eyeball everything. Thanks for your response.

Added after the I looked again.

Did a thorough cleaning: checked the gas ports they were clean, cleared one of the four holes in the gas relief cylinder, pulled the trigger group cleaned and lubed and used the compressed air to remove any extra lubricant from trigger group and so on. Reassembled with a wet gas system...

Took it to the range and it worked perfectly. Will run some more rounds tomorrow and when it runs perfectly I will scratch my head and wonder why I reported a problem in the first place. My current theory is that the 391 wanted more attention after running many thousands of rounds with any problems.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top