Shotgun Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
129 Posts
Discussion Starter · #1 ·
Anyone had any problems out of their SBE 2 please post just curious. I had heard the wouldnt cycle light loads well. all the ones ive seen work fine
 

·
Registered
Joined
·
3 Posts
I purchased a SBE 2 about 3 months ago and I haven't had any problems at all. I didn't do any break-in at all. The first day that I got the gun I cleaned it to get the packing grease out of it and took it to the skeet range. It cycled lite trap loads on day 1 with no problems. Since then I've shot geese and ducks with 3 and 3 1/2 inch loads and have never had a cycling problem with them either.

I don't shoot very expensive loads either. Pretty much the cheapest I can find. So far I've been very happy with this gun. It's a work horse.
 

·
Registered
Joined
·
550 Posts
If you use heavy lube it can gunk up. Use a light lube like what is supplied with the gun or something that stays thin in the cold weather and it will work flawlessly.

That is the main reason so many people like them. There are less parts and no gas rings or gas systems to gun up. There are only 3 parts to the bolt assembly and a spring in the magazine and one in the stock. That is it. SUPER simple and reliable.

CR

P.S. If you break it in with biggest loads you can get it will cycle the light stuff, no problem. Just stay above (what I have found 1200FPS) and you will be fine. I have shot a bunch of 1145 and 1170FPS 1oz in my SS with no issuess. The field models have heavier recoil springs SO keep it above 1200fps to be safe.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top