Shotgun Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
614 Posts
Discussion Starter · #1 ·
Guys im sure this isn't the kinda stuff this forum is really for but I just gotta tell someone who is old enough to appreciate it about my A5. I've been messing with this thing for about a year trying to sort out jamming problems. Not working at hard enough to fix but just hard enough to frustrate me to the point I stood it in the corner and said to hell with that thing I'll see bout it later. Wound up completely disassembling and cleaning it chamber and all several times and changed out every spring in it mosty one at a time and every time had some luck but always wound up the same place! About every 5 or maybe 8 rounds it was all jammed up. Turns out the problem was it was dirty, the chamber was 50 plus years of filthy, the springs were all 1953 modle just like the gun im sure and to top it all offand cause the loss of the little hair i had i got hold of 6 cases of Herters ammo that in this particular gun failed to eject cleanly every time due to fired lenght plus funky brass that lacks nice sharp corners for the ejector to get a dependable purchase on. So after all was said and done plus the arrival of a couple cases of rem game loads today we went to the skeet range and i shot 5 rounds and the grandkids totaled another 9 rounds and we had ZERO malfunctions! Im the happiest old guy!it was just making me sick that I couldn't fix that damn thing, to the point that i had been considering if i had what it would take to walk in the doorof a gun shop and tell them i was to stupid to get me gun to work! I couldn't fix my own a5! My God! I'm not sure I could ever have lived with myself if it had gone that far.
Anyway thanks guys for the help along the way!
YEE HA!!!! Not one jam all day ! My faith is restored at last!!!! There's nothing finer than a well tuned old A5 16gauge!!
 

·
Registered
Joined
·
344 Posts
If it acts up use a bore brush wrapped in 000 steel wool chucked up in a drill and polish the chamber with it. use some solvent the chamber might look clean now but this really works
 

·
Registered
Joined
·
383 Posts
Congrats on getting your old classic running again. So often with autos it's being excessively dirty or the ammo that's the culprit.
 
1 - 4 of 4 Posts
Top