Shotgun Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
228 Posts
Discussion Starter · #1 ·
When fired I am unable to pull the slide back, I have to push the slide forward and then pull back. I swapped in a whole trigger group from another m12 and it worked perfectly. So I started looking for the differences and found the slide lock had a broken spring, I replaced this and reassembled the original trigger group. It works better but any slight pulling action on the slide (before the trigger is pulled) causes the same jamb situation. It seems like trouble with the slide lock but I can't find it. Anyone ever run across this?
 

·
Registered
Joined
·
6,973 Posts
Lets be clear on what is happening. Are you actually firing the gun with a shell and having this problem or are you dryfiring it and experiencing the problem? When you dryfire you do have to push the slide foward slightly to release it to work the action. When you actually shoot the gun the inertia of the forend takes care of that and it unlocks without you being aware of it (that is, if it is working right)
 

·
Registered
Joined
·
228 Posts
Discussion Starter · #3 ·
Oh!
I was dry firing (snap cap).
I was comparing it to the other M12 I have that is older and has alot more rounds through it. That older gun dry fires and releases with no need to push forward to release the lock. The slide lock doesn't work real well in the old gun.

By the sounds of it my newer M12 is working as it should.
Thanks for the post it was quite helpful.
 
1 - 3 of 3 Posts
Top